MikroTik Hairpin NAT, доступ с локальной сети по внешнему ip

Краткое описание: Руководство по настройке MikroTik Hairpin NAT, организация доступа к локальному адресу по внешнему IP.

Нужно настроить MikroTik Hairpin NAT?

Настройка сервисов на маршрутизаторах MikroTik: подключение интернета, DHCP, brige, VLAN, WiFi, Capsman, VPN, IpSec, PPTP, L2TP, Mangle, NAT, проброс портов, маршрутизация(routing), удаленное подключение и объединение офисов.

Что такое Hairpin NAT

Что такое Hairpin NAT

Частая ситуация: после проброса порта и попытки обратиться из локальной сети по внешнему адресу завершается неудачей — не приходит ответ от указанного узла. И эта ошибка приводит в замешательство специалиста, привыкшего настроить роутер Asus, D-Link, Linksys, Netis, Tp-Link, Tenda, Xiaomi, Zyxel, Keenetic, Mercusys, Edimax.

Суть метода Hairpin NAT заключается в том, чтобы обращение по внешнему адресу переадресовывалось на локальный порт. Т.е. весь трафик будет просто заворачиваться с подменой адресов(NAT).

Типичные примеры:

  • доступ к видеонаблюдению;
  • сайту, размещенному в локальной сети;

Настройка MikroTik Hairpin NAT

Для этого нужно сделать два последовательных правила:

Настройка находится в IP-Firewall-NAT

/ip firewall nat add chain=dstnat dst-address=1.1.1.1 protocol=tcp dst-port=80 \ action=dst-nat to-address=192.168.1.2 add chain=srcnat out-interface=WAN action=masquerade

/ip firewall nat add chain=srcnat src-address=192.168.1.0/24 \ dst-address=192.168.1.2 protocol=tcp dst-port=80 \ out-interface=LAN action=masquerade